Loom Intermittent Issues

Incident Report for Loom

Resolved

Between 18:45 and 19:35 UTC we experienced degraded functionality for Loom. The issue has been resolved and the service is operating normally.
Posted Aug 15, 2025 - 19:58 UTC

Monitoring

We have identified the cause of the issues and we are monitoring recovery.
Posted Aug 15, 2025 - 19:50 UTC

Identified

We are investigating reports of issues for Loom customers. Including names showing as IDs. We will provide more details once we identify the cause.
Posted Aug 15, 2025 - 19:35 UTC
This incident affected: Recording, Viewing, Authentication, and Loom AI.