Customers unable to checkout with loom monthly plans

Incident Report for Loom

Resolved

This issue is now resolved and customers can checkout as expected.
Posted 22 days ago. Apr 14, 2025 - 19:34 UTC

Monitoring

A fix has been implemented and we are monitoring the results
Posted 22 days ago. Apr 14, 2025 - 19:30 UTC

Identified

Customers are unable to choose a monthly plan when upgrading or purchasing from loom.com. We are investigating this issue.
Posted 22 days ago. Apr 14, 2025 - 19:07 UTC