Degraded performance of Loom app

Incident Report for Loom

Resolved

The Team has identified the root cause and the issue has now been resolved, and the impacted services are operating normally. Team will continue to monitor the impacted services.
Posted Apr 29, 2026 - 07:50 UTC

Investigating

We are investigating degraded performance issues affecting Loom's core functionalities - authentication, recording, viewing and editing looms.
We will provide more details within the next hour.
Posted Apr 29, 2026 - 07:00 UTC
This incident affected: Recording, Viewing, Authentication, and Loom AI.